Contents - Index


Troubleshooting


Important: If some or all of your control programs are not started, CCDAutoPilot will attempt to start them in what should be the proper order.  Depending on your PC's performance, they may or may not start properly.  If things don't seem to be operating properly, start them manually before starting CCDAutoPilot.  For example, assume you are using RoboFocus to control your focuser, FocusMax for focusing and CCDSoft to control your camera.  Load and start RoboFocus, confirming it connects to and can control your focuser hardware.  Next Load CCDSoft, confirming it connects to your camera.  Take a short image to be sure.  Next, load FocusMax since it must control both RoboFocus and CCDSoft.  Finally, load CCDAutoPilot. 

Similarly, when closing programs, close CCDAutoPilot first, then the other programs. In the above example, close FocusMax then close RoboFocus if it is still open. Failure to do this may lead to vestiges of programs running that must be manually terminated in Task Manager.

See Computer Notes for any failures to connect to server applications (control programs).

If you haven't read Introduction to Automation yet, I strongly recommend you do.


Step-by-step

1. Make sure the .NET  4.0 framework extended edition is installed.  You can verify its installation by going to Control Panel, Add/Remove Programs and making sure there is an entry for "Microsoft .NET Framework 4 Extended". If that entry is not present, please install it before proceeding. See the Application Requirements topic for a link to the Microsoft download location.

2. Insure installation of all programs required for your operation is proper and functional by testing them standalone.  See  the Application Requirements topic for links to all programs.  Make sure you are using the latest version of CCDAutoPilot.  The most recent version information and change history can be found here.

3. Verify you have the minimum version level for the above programs.  CCDAutoPilot will warn of out-of-revision programs and prevent operation.  See the Application Requirements topic for minimum version requirements.  Of course, higher version numbers can be used.  Program version numbers can generally be checked by the Help | About menu on the individual program.  For programs that do not support this feature, you must locate the program's .exe file, right click on it, select properties and select the version tab.

4. Before connecting CCDAutoPilot to any of your programs, be sure the programs are able to properly control their related hardware.  Can you take an image with your camera control program?  Can you slew the telescope with your telescope control program?  Can you control your focuser and focus with your focuser program?  Does your rotator program control your rotator?  Does your dome control program move your dome?

5. Connect to CCDAutoPilot and use the test buttons on the Preference page, Tools Tab to verify CCDAutoPilot is able to control the appropriate hardware through your programs.

6. On the Session Page, Light Frames phase, create a target using the Get function with TheSky or the Add a target manually. Select the target if it is not selected using the Row Header.  Right-click and select Slew To Target Uncorrected.  Does the mount slew properly?

7. Set up a single, short exposure on Session Page, Light Frames phase.  Run a short session to confirm the telescope slews to the target and takes a short exposure.

8. Add other functions and complexities gradually, verifying proper operation with each addition.


When things don't go as expected

While every effort has been made to trap invalid user entries, some slip by.  These are addressed as they are identified but with over 600 controls, there is a lot of opportunity for bad entries or combinations.  Here are some techniques to help resolve such a problem.
  • Global Error Handler: CCDAutoPilot traps and handles many potential errors during the course of a session.  Occasional setup and input errors can lead to errors as well (unhandled exceptions).  Should the latter error occur, CCDAutoPilot will present a window with choices on how to capture the error information.  Next, CCDAutoPilot will attempt to run a script named RunOnError.vbs located in 
  • (My)Documents\CCDWare\CCDAutoPilot5\ if it exists.   Finally CCDAutoPilot will close.   If the error is repeatable and the next steps don't resolve the issue, feel free to post the error file to the CCDWare support forum for assistance.
  • Reset: If CCDAutoPilot fails to load, selecting CCDAP4 Reset from the Start menu resets all key data as if CCDAutoPilot were never installed (except for the trial period status of course).   Your system profile(s) and target list(s) are not affected. You can also access this function by holding down the Control key on your keyboard while double-clicking on the CCDAutoPilot icon. 
  • Create a new System Profile: From the System Profile menu, select New to create a new system profile.  Of course you will need to re-enter all your settings but often this resolves the issue of a bad setting.
  • Task Review: Open Task manager and select the Processes tab.  If you click on the Image Name table header, the processes will be sorted in alphabetical order for easy viewing.  Verify that one and only one process is running for each server program you have operating.  If you see more than one process, then proper automation is not possible.  You should either reboot your PC (easiest) or close all programs and use the End Process button to stop any server programs that remain running.  This can happen when a run is aborted and the abort process is not allowed to complete.  After hitting the Abort button on the status window, remember to wait until the main window restores (re-opens).  This minimizes the chance of multiple processes in task manager.
  • Hardware: If things suddenly stop behaving properly or you experience heretofore unexplained hangs, it is most likely a hardware problem. Check all USB connections. Make sure you do not depend on connector retention force to hold the cable in place but rather strain relieve all USB cables so you can pull on them without unplugging them. As a diagnostic, bypass any hubs, especially if not of commercial (usually more expensive) quality. Office quality hubs can be problematic unless you operate your observatory with electronics in a temperature controlled environment between 10 and 35C. The same is true of serial-USB converters. Insure proper voltages are being delivered to your cameras and other equipment.



    Troubleshooting Tools




  • Information (Read First): links to the Troubleshooting Overview.
  • Trace: The Trace facility provides diagnostic information for various phases of CCDAutoPilot operation.   While the Session window and the attendant log provide event logging during an active run, there are possible occasions when things don't go as expected before starting an actual session.  The trace facility can be used whenever things don't seem to be "working right" before running a session.  Trace also provides more detailed information during a session. When Trace is enabled, all plate solve frames are saved, not just the failed ones.  This can be handy to diagnose plate solving issues but be aware that leaving Trace enabled will consume more disk space as all plate solve frames are saved.   When this topic is selected, CCDAutoPilot's trace facility is turned on and CCDAutoPilot closes.  When CCDAutoPilot is next started, the trace facility is engaged and  a trace file will be written in the CCDAutoPilot5 data directory.  The data directory is located at My Documents\CCDWare\CCDAutoPilot5 (XP and Prior) and Documents\CCDWare\CCDAutoPilot5 (Vista/Windows 7).A new file is written each time CCDAutoPilot is started.  The file has a file name of Trace<yyyymmdd>_<HHmmss>.log and will record any error messages.  When Trace is enabled, all plate solving images ("Sync_Image") are saved, whether successful or not.  Trace being on is indicated by a check next to the Help menu selection.  To turn Trace off, select this topic again.  CCDAutoPilot will close and Trace will be disabled when CCDAutoPilot is next started.  Contact support for interpretation of any messages in the trace file.

  • Remove and Reinstall CCDAutoPilot: While this should not be necessary. it has been shown to help resolve some unique issues.  This should be used in conjunction with the CCDAutoPilot Reset Tool.  First remove CCDAutoPilot then run the CCDAutopilot Reset Tool.  If possible, it is a good idea to reboot your PC before reinstalling.


    Support

    If none of the above resolves the issue you are having, please use the CCDAutoPilot support forum, which is also accessible from the Help menu.  If you have problems during a run, be sure to post the related .log file as an attachment.  If you are having problems that prevent a run from starting, post the error log file described above. The more detail you include in your problem report along with the suggested attachments, the more quickly the issue can be resolved.